Questions

Answer

How to use Shadowbox with a flash component

First, download and install Shadowbox (possibility to pop-up images, videos and SWFs) using their tutorial.

Next, in your images.xml file at the url (or link for some components) attribute try to specify something like this:

url="javascript:LaunchShadowbox('images/01.jpg','img','First Image')" target="_self"

Also in your HTML file that embeds the SWF you'll have to write the following JavaScript code between the <head></head> tags:

<script type="text/javascript">
function LaunchShadowbox(url,player,title){
Shadowbox.init();
Shadowbox.open({content: url, player: player, title:title});
}
</script>

Note that the Mediabox will not work if tested locally. You’ll have to test it on a HTTP server.

Comments

  • Page:
  • <
  • 1
  • 2
  • 3
  • 4
  • 5
  • loading comments...

Jeremy Francis

Posted 9 years ago

Hi I also have mine on a wordpress install and the carousel works, but the links don’t work. When I click on an image nothing happens, I’d like them to open either a page in the shadow box, or a the content within a hidden div, but for some reason when I click nothing happens… Any help would be great, once we get it working we want to buy the full version, so I hope we can get it working soon.

FlashXML Support

Hi,

In your images.xml file you have this line as an example:

<photo image="images/Action_Coaching.png" bigimage="images/big/Action_Coaching.png" url="javascript:LaunchShadowbox('images/big/Action_Coaching.png','img','First Image')" target="_self">Click Here To Preview The Course!</photo>

You have to specify the absolute path to the big images you’re trying to use to make it work.

John

Posted 9 years ago

Hello, I want to incorporate shadowbox into the 3d carousel menu FX animation. I’m using Wordpress and have uploaded the plugin for shadowbox and I’ve changed the images.xml file accordingly. When I click on an image in the rotating carousel, the shadowbox feature begins working, ie the screen darkens, a black box opens in the center of the page and the ‘loading’ animation begins. The large picture is never opened, however. The ‘loading’ status runs continuously. What can I do to get this to work? I am on a very tight time frame with this project. Thank you very much in advance for your help! I will copy/paste a bit of the carousel coding from the images.xml file for your reference. Regards, John.

FlashXML Support

Hi,

There’s no need to paste all that code. Just give us the link to your website and we will check it.

  • loading comments...
  • Page:
  • <
  • 1
  • 2
  • 3
  • 4
  • 5

Do you have a question?

you will get an answer in 24 hours, tops.

(required) Only alphanumeric characters allowed
(required) (will not be published)
Please type a message! Your message is too long! Either try to keep within 1500 characters, or contact our support team via email at support [at] flashxml.net.
(will not be published)
You mistyped the two words!
Can't read? Change the image
Format your comments using Textile: *bold*, _italic_, "link text":address, @code@
Connect to us on Facebook Follow us on Twitter Subscribe to our RSS feed
Copyright © FlashXML.net 2009 - 2020